ago 052015
 

No último artigo mencionei que tenho um pequeno servidor com Vmware ESXI 5.5.

Mas decidi que era hora de fazer o upgrade desse Vmware para ESXI 6.0, que é a versão mais atual do ESXI.

Talvez a princípio isso pareça simples, mas não é bem assim.

A partir do Vmware 5.5 a Vmware decidiu remover o suporte a alguns hardwares, e tirou o driver deles da instalação. Obviamente que esses drivers removidos suportavam na maioria das vezes os hardwares mais baratos, ou seja, normalmente os que usamos.

Existem inúmeros sites que explicam como instalar esses drivers removidos do instalador padrão (um deles altamente recomendado é o Vmware Front Experience). Mas o problema é que no Vmware ESXI 6.0 esses drivers entraram numa black-list, ou seja, a instalação deles ficou ainda mais complicada.

Agora com toda essa explicação e introdução, vamos ao que interessa.

Como atualizar do Vmware 5.5 para o Vmware 6.0 sem perder os meus drivers ?

Atualização do VMWARE 5.5 para 6.0

Primeiramente verifico os drivers que tenho:

~ # esxcli network nic list
Name    PCI Device     Driver  Link  Speed  Duplex  MAC Address         MTU  Description                                        
------  -------------  ------  ----  -----  ------  -----------------  ----  ---------------------------------------------------
vmnic0  0000:004:00.0  e1000e  Up     1000  Full    68:05:ca:29:e6:7c  1500  Intel Corporation 82574L Gigabit Network Connection
vmnic1  0000:005:00.0  r8168   Down      0  Half    f8:1a:67:05:05:c8  1500  Realtek Realtek 8168 Gigabit Ethernet              

Sei que o R8168 esta na Black-List.

Faço o Workaround exposto nesse blog:

# Lower the system's acceptance level to allow Community supported packages
~ # esxcli software acceptance set --level=CommunitySupported
# open firewall for outgoing http requests:
~ # esxcli network firewall ruleset set -e true -r httpClient
# Install e.g. net55-r8168 from the V-Front Online Depot
~ # esxcli software vib install -d https://vibsdepot.v-front.de -n net55-r8168
Installation Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: Realtek_bootbank_net55-r8168_8.039.01-napi
   VIBs Removed: VMware_bootbank_net-r8168_8.013.00-3vmw.510.0.0.799733
   VIBs Skipped:
# Reboot
reboot

E faço o upgrade usando o método que eles também explicam, que é um repositório online da Vmware – VMware Online Depot:

# open firewall for outgoing http requests:
esxcli network firewall ruleset set -e true -r httpClient
# Install the ESXi 6.0 Imageprofile of 2015-04-09 from the VMware Online Depot
esxcli software profile update -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml -p ESXi-6.0.0-20150404001-standard

Update Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: VMWARE_bootbank_mtip32xx-native_3.8.5-1vmw.600.0.0.2494585, VMware_bootbank_ata-pata-amd_0.3.10-3vmw.600.0.0.2494585, VMware_bootbank_ata-pata-atiixp_0.4.6-4vmw.600.0.0.2494585, 
   ...
   VIBs Skipped: 

# Reboot your host
reboot

Pronto !

Espero que possa ser de ajuda !

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)